[Elevate] Increased response times on various storefront API endpoints

Incident Report for Voyado

Postmortem

A release of Elevate introduced a bug in the calculation of promotion statistics, which caused CPU exhaustion leading to performance degradation of some Storefront endpoints.

When noticed, the release was aborted and rollback was made to the previous version.

The endpoints primarily affected were the landing-page and the product-page.

Not all customers were affected.

Posted Jan 23, 2026 - 15:28 CET

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 12:35 CET

Monitoring

The latencies are improving and we continue to monitor the situation.

Not all customers were affected.
Posted Jan 20, 2026 - 12:01 CET

Identified

We have identified the issue and are preparing a rollback.
Posted Jan 20, 2026 - 11:30 CET

Investigating

We are currently investigating this issue.
Posted Jan 20, 2026 - 11:20 CET
This incident affected: Elevate (API).