[Engage] - FTP server is currently unavailable
Incident Report for Voyado
Resolved
FTP is back online.
Posted Apr 22, 2024 - 11:22 CEST
Investigating
The FTP server ftp.voyado.com is currently unavailable. We are actively investigating.
Posted Apr 22, 2024 - 11:03 CEST
This incident affected: Engage (FTP).