[Engage] System Performance Degradation

Incident Report for Voyado

Postmortem

Summary

On June 3, 2025, the Engage platform experienced a service degradation affecting customers in general, primarily through slower response times in API calls.

Customer Impact

Customers on the Engage platform had problems with slower API calls. The issue began around 14:45 CEST and was resolved by approximately 16:00 CEST.

Root Cause and Mitigation

An unusually high volume of updates from one part of the platform created a bottleneck in the system. While the impact should have been limited to just a few customers, the temporary overload affected the platform more broadly.

Once we identified the source of the issue, we took action to relieve the pressure. This allowed the platform to recover and return to normal operation within the hour.

Next Steps

As part of our ongoing commitment to platform reliability, we’re making improvements to reduce the risk of problem with one area impacting others.

We appreciate your patience and understanding, and apologize for any inconvenience. We remain committed to providing a stable and reliable platform experience.

Posted Jun 30, 2025 - 12:41 CEST

Resolved

After closely monitoring the situation, we can now confirm that the incident has been resolved. The steps we took to address the issue have held up, and the platform has been stable since.

We know this disruption caused real headaches and we’re genuinely sorry for the impact it had. While we’re not in a position to point to an exact root cause just yet, our team is deep into the investigation. Once we have a full picture, we’ll share a detailed post mortem outlining what happened and what we’re doing to make sure it doesn’t happen again.

Thanks for bearing with us, and we appreciate your patience and trust.
Posted Jun 03, 2025 - 18:33 CEST

Monitoring

The fix has been implemented and we are seeing positive results since a few minutes back.
We will continue to monitor the performance to make sure the positive effect of the fix is not temporary.
Posted Jun 03, 2025 - 16:03 CEST

Identified

We have found the source of the degradation and are working on a fix.
Posted Jun 03, 2025 - 15:58 CEST

Update

We are continuing our investigations.

We have not been able to mediate the effects and still see service degradation across most parts of the platform.
Posted Jun 03, 2025 - 15:27 CEST

Update

We are continuing to troubleshoot at full force.

At the moment we can see service degradations for most customers and across a variety of functionality including the API:s and the user interface in the application.
Posted Jun 03, 2025 - 15:08 CEST

Investigating

We are currently investigating indications of general slowness and degraded performance. Users may experience unusually long loading times, this may also affect processing times in automations and sendouts.
Posted Jun 03, 2025 - 14:51 CEST
This incident affected: Engage (API, Web Application, 3rd Party Integrations).