Resolved: Following earlier performance degradation, all services have been operating normally since yesterday.
We will continue to monitor to ensure stability.
Posted Apr 10, 2026 - 13:13 CEST
Monitoring
We are currently seeing stable system performance since 12:30. The issue causing intermittent degraded performance appears to be mitigated, and we are continuing to monitor closely.
Posted Apr 09, 2026 - 16:41 CEST
Update
We are currently seeing that system performance has stabilized following the recurrence of yesterday’s issue. We are continuing the investigation to identify the root cause and is actively testing additional measures to fully resolve the problem. Further updates will follow as we progress.
Posted Apr 09, 2026 - 14:41 CEST
Investigating
The issue with intermittent degraded performance from yesterday has returned, the remediations made yesterday seems not to be sufficient. Investigation ongoing.
Posted Apr 09, 2026 - 11:38 CEST
This incident affected: Engage (API, Messaging, Automations).