[Engage] Issues logging in
Incident Report for Voyado
Resolved
This incident has been resolved.
Posted Oct 15, 2024 - 10:28 CEST
Identified
We are currently seeing issues with logging in to the platform and are working on a fix.
Posted Oct 15, 2024 - 09:42 CEST
This incident affected: Engage (Web Application).