Voyado telecommunications outage for incoming calls

Incident Report for Voyado

Resolved

This has been reported as resolved from our provider.
We apologize for any inconvenience caused by the outage.
Posted Jan 28, 2026 - 14:14 CET

Identified

We have been alerted by our provider that they are having an issue with our telephony services and we are currently unreachable by phone.
Please contact us through https://help.elevate.voyado.com or https://help.engage.voyado.com.
You may also email support@voyado.com.
Posted Jan 28, 2026 - 09:03 CET
This incident affected: Other services.