Shopify app - 504 Gateway Time-out
Incident Report for Voyado
Postmortem

504 Error Incident Due to Database Indexing Issue

Incident Summary

  • Date of Incident: 2024-09-03
  • Time of Incident: 11:40 (CET)
  • Duration: 10 minutes
  • Impact: The application experienced a 504 Gateway Timeout error, affecting users' ability to access data from the customers table.

Root Cause

The 504 error encountered this morning was caused by a database indexing issue. Specifically, the voyado_id field in the customers table did not have an index. As a result, the application faced delays while trying to retrieve data, leading to the 504 Gateway Timeout error.

Resolution

The incident was resolved by rolling back the schema change applied the day before, which removed the issue of inefficient queries caused by the missing index.

Posted Sep 04, 2024 - 07:18 CEST

Resolved
This incident has now been resolved and more information to come.
Posted Sep 03, 2024 - 12:00 CEST
Investigating
We are experiencing issues with the app and are currently investigating and trying to resolve the issue as soon as possible.
Posted Sep 03, 2024 - 11:45 CEST
This incident affected: Engage (3rd Party Integrations).