Elevate Apps is currently unavaliable
Incident Report for Voyado
Resolved
This incident have been resolved, if you experience any issues send a ticket to support@voyado.com
Posted Oct 28, 2024 - 11:04 CET
Monitoring
Up and running and we are monitoring the situation
Posted Oct 28, 2024 - 10:54 CET
Investigating
We are currently investigating the issue.
Posted Oct 28, 2024 - 10:50 CET
This incident affected: Elevate (Apps).