[Engage] Service Disruption

Incident Report for Voyado

Postmortem

Summary
On August 20th, we experienced an issue affecting connectivity and performance in our API Gateway. The incident was identified and resolved within a short time frame.

Customer impact
During the incident, some customers experienced degraded performance and intermittent connectivity issues when accessing the API Gateway. Other platform functionality remained unaffected.

Root cause
The issue was caused by an SSL certificate deployment that introduced unexpected connectivity and performance problems.

Mitigation
Once identified, the deployment was quickly reverted, which immediately stabilized the platform. A permanent fix has since been implemented, and no further performance degradation has been observed.

Next steps
We have updated our deployment routines and processes to ensure similar issues are avoided in the future.

Posted Aug 26, 2025 - 09:21 CEST

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 17:17 CEST

Update

We are continuing to monitor for any further issues. Current performance remains stable and has been looking good since the implemented fix.
Posted Aug 20, 2025 - 15:21 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2025 - 14:57 CEST

Investigating

We are currently investigating a potential disruption. At this stage, information is limited, further updates will be shared as soon as possible.
Posted Aug 20, 2025 - 14:29 CEST
This incident affected: Engage (API).