Elevate App

Incident Report for Voyado

Postmortem

A separate service from a third party/vendor is used to host the Elevate application. Due to an error in their invoicing service the Elevate application was suspended.

Posted Jul 24, 2025 - 09:06 CEST

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 20:47 CEST

Investigating

We are currently investigating this issue.
Posted Jul 22, 2025 - 18:35 CEST
This incident affected: Elevate (Apps).