Voyado - Microsoft 365 (business) delay in delivery

Incident Report for Voyado

Monitoring

Microsoft has acknowledged this issue here: https://x.com/MSFT365Status and we kindly ask our customers to re-visit this page for more updates in this matter.
Posted Sep 04, 2026 - 16:31 CEST

Investigating

At the moment, there are intermittent issues with email deliveries at Microsofts Exchange Online services. This means that you may see more emails in status "Unknown" for your sendouts than you normally do in Engage.

This is a know issue at Microsoft and they are looking into this. Please see here more more information: https://portal.office.com/adminportal/home#/servicehealth

(Note that you have to be a 365-admin to be able to access this link)

We are also seeing this affecting responses from our support ticketing system not being delivered. If you have sent in tickets and not received any response, you can log in to our help center to check for responses. https://explore.voyado.com
Posted Sep 04, 2026 - 14:39 CEST
This incident affects: Other services.