The remediative actions had the desired effect and we are now back at normal operations.
Posted Sep 08, 2025 - 13:15 CEST
Identified
We have identified the issue and taken remediative actions. We are not yet at normal operations but we see indications that the delays are decreasing.
Posted Sep 08, 2025 - 12:45 CEST
Update
We are continuing to investigate the issue with top priority.
We can see that many areas of the platform are currently affected by the disturbance, from slow/unresponsive APIs to delays in automations and message delivery.
Posted Sep 08, 2025 - 12:34 CEST
Investigating
We are currently investigating indications of general slowness and degraded performance. Users may experience unusually long loading times and slow/unresponsive APIs, this may also affect processing times in automations and sendouts.
Posted Sep 08, 2025 - 12:27 CEST
This incident affected: Engage (API, Web Application, Messaging, Automations, 3rd Party Integrations).