Delay in messages delivery for some messages
Incident Report for Voyado
Resolved
All operations affected by the disturbance have been recovered and Voyado is now operating normally.
Posted Mar 12, 2024 - 18:29 CET
Investigating
We have identified a disturbance in Voyado and are working on restoring normal operations as soon as possible.
Posted Mar 12, 2024 - 16:59 CET
This incident affected: Engage (Messaging).