Voyado Engage - Emails delayed
Incident Report for Voyado
Resolved
The incident has now been resolved, all the messages that was delayed has been resent.
Posted Nov 27, 2024 - 18:53 CET
Investigating
We are currently experiencing delays in sending emails. We are working to resolve the issue.
Posted Nov 27, 2024 - 18:01 CET
This incident affected: Engage (Messaging).