Engage - issues with registration forms redirection not working

Incident Report for Voyado

Postmortem

Summary

On 2 June 2026, we identified an issue where short links used in SMS campaigns did not redirect users to the intended destination. Instead, recipients were redirected to the login screen. The issue was resolved the same day.

Customer impact

The issue affected customers using short links in SMS campaigns, including links to registration forms and mobile swipes. The impact period was approximately 15:40–18:17 CEST.

Root cause

A code change introduced in the release on 2 June changed how short link redirects were handled. As a result, some SMS short links redirected to the login screen instead of the intended page.

Mitigation

A hotfix was developed, verified, and deployed to production. The fix was confirmed working in production before the incident was marked as resolved.

Next steps

We have updated the relevant test coverage and will continue improving end-to-end testing for features using short links.

Posted Jun 15, 2026 - 09:39 CEST

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 18:17 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 17:56 CEST

Identified

The issue has been identified and a fix is currently being tested before hotfix can be deployed.
Posted Jun 02, 2026 - 16:32 CEST

Update

The issue is limited to links to registration forms sent via SMS.
Posted Jun 02, 2026 - 16:00 CEST

Investigating

We are seeing issues with short-URLs in reg forms not redirecting properly. This is being investigated.
Posted Jun 02, 2026 - 15:44 CEST
This incident affected: Engage (Other).