[Engage] Contact lookup Performance Degradation

Incident Report for Voyado

Resolved

The affected service is restored back to normal and contact lookups are now fully operational again.
Posted Jul 02, 2025 - 20:51 CEST

Update

This issue is still being investigated by our provider. Current status and more detailed updates can be followed here: https://status.dnb.com/.

We will keep you informed about the development as we learn more.
Posted Jul 02, 2025 - 17:47 CEST

Investigating

We are currently experiencing service disruptions due to an issue with an external provider. This may affect the availability or performance of contact lookups for the subset of customers which are using this feature. We are monitoring the situation closely and will provide updates as more information becomes available.
Posted Jul 02, 2025 - 16:31 CEST
This incident affected: Engage (3rd Party Integrations).